[brite-users] issues running on cygwin

Simon Wilkinson simon.wilkinson at gmail.com
Fri Sep 1 11:13:24 EDT 2006


Hi,

I am trying to get BRITE running under Cygwin, and am having some issues.
First I tried running "make all" under the main Brite/ directory.  When I do
this, I get no errors, but also no other signs of make running.  It simply
returns to the command prompt.  I then tried running BRITE using "./brite
&", but then I get this error: java.lang.NoClassDefFoundError: GUI/Brite
Exception in thread "main"

I thought this might be because of not having the PATH variable set
properly, so I made sure to add the path to my Java bin directory to my
PATH, but I still get the same error.

I then tried just compiling the C++ version, by going into the C++/
subdirectory, and typing "make".  Everything here compiled successfully, but
I still can't get it to run using the GUI.  I tried using the "startGUI"
command as listed in the online documentation/user guide, but it says that
the command is not found.  When I try running the command line versions
(using "run cppgen <conf-file> <output-file> <seed_file>") it starts up, but
then hangs right after it prints out the line "random placement...".  At
this point the cppgen process is running at about 98% cpu usage, and stays
like that.  I was only trying to create a topology of 5 nodes, using the
RTBarabasi5.conf file.  Is this normal behaviour?  How long does it
typically take to generate a topology?

So next, I went into the Java/ subdirectory, and tried running the Makefile
in there.  When I tried that, I got the following:
Note: Some input files use unckecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details
72 errors
make: ***[all] Error 1

It seems that all the errors are complaining about not being able to find
the symbol "Topology", and this seems to stem from not being able to find
the Topology package.  I am running Java JDK 1.5.0_08 (the latest release).
The Topology subdirectory is present in the Java directory.

I am wondering if anybody else has run into this type of problem, and if so,
if they have any suggestions as to how to solve it so that I can use the
GUI.  Alternatively, I noticed in the README that compiled binaries are
available upon request, so if this could be sent to me so that the GUI would
be useable, that would also be appreciated.

Thanks,

Simon
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://cs-mailman.bu.edu/pipermail/brite-users/attachments/20060901/58029538/attachment.html


More information about the brite-users mailing list