[brite-users] Plot a topology

Massimo Canonico canonico at mfn.unipmn.it
Mon Feb 6 09:01:36 EST 2006


Michael,
I have tried to do what you suggested, but I still get a parse error.

I attached the NS file from BRITE after the modification that you 
suggested. Moreover, I copied below what Emulab PS parsed said:


    Parse Failure(1): Output as follows:


wrong # args: should be "proc name args body" while executing "proc 
create_topology {} { global ns #nodes: set num_node 10 for {set i 0} {$i 
< $num_node} {incr i} { set n($i) [$ns node] } #links: set..." (file 
"15849.ns" line 3029) invoked from within "real_source 
${GLOBALS::nsfile}" invoked from within "if { ${GLOBALS::errors} != 1 } 
{ file copy -force ${GLOBALS::tbcompat} . real_source ${GLOBALS::nsfile} 
if {${GLOBALS::ran} == 0} { perr..." (file 
"/usr/testbed/lib/ns2ir/parse.tcl" line 578) *** ERROR: parse-ns: 
Parsing failed (error code 1)! NS Parse failed!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: briteCor.tcl
Type: application/x-tcl
Size: 2228 bytes
Desc: not available
Url : http://cs-mailman.bu.edu/pipermail/brite-users/attachments/20060206/7b60fa58/briteCor.tcl


More information about the brite-users mailing list